Back

Restarting stuck actions

January 29, 2025, 6:34 AM UTC Resolved after 2d

Updates

Resolved

All affected actions (extractions and following flows) were restarted. In each affected extraction log, you find the execution with "failed to set timeout: deadline can't be prolonged" error.

The extractions/flows behavior is now as expected.

January 29 9:24 AM UTC
Identified

We ran command/script to restart all stuck extractions. Such action's last execution log result to be "broken" and the new execution would start immediately. If the extraction has following flow attached this will be triggered automatically once the extractions finishes with no error.

January 29 7:48 AM UTC
Identified

We have identified that extractions were executed according to their scheduled configurations. However, the extractor component failed to send results to the result queue.

This issue affected all extractions processed in the AWS environment, while extractions in the GCP environment remained unaffected.

We are now updating all affected actions to a “broken” status and will restart them to ensure the triggering of subsequent flows.

January 29 7:11 AM UTC
Investigating

Jobs are processed longer than usual

January 29 6:40 AM UTC